Starcraft 2

Todos los temas relacionados con Starcraft 2.
 
ÍndiceCalendarioFAQBuscarMiembrosGrupos de UsuariosRegistrarseConectarse

Comparte | 
 

 Problema con activadores (Solucionado, se muestra solución)

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
Dehzerus
Zeratul


Mensajes : 107
Fecha de inscripción : 26/04/2011

MensajeTema: Problema con activadores (Solucionado, se muestra solución)   Lun Sep 26, 2011 4:11 pm

Buenas, estoy creando un mapa que pienso completar si o si, lo que pasa es que no soy capaz de averiguar lo que sucede.

El problema esta en que tengo unas variables locales en un activadores que deberían de cambiar de valor pero no lo hacen, a mi ya no se me ocurre nada más y no se que hacer...

Es muy largo explicaros el problema, así que si os podéis mirar el mapa directamente será mejor, los activadores que fallan están en una carpeta (la única que hay)

Yo ya no se me ocurre nada de nada, estoy muy clavado y no he hallado ni el problema, así que imaginaos como estoy de harto de ir testeando el problema.

http://www.megaupload.com/?d=5D6S70OF

Gracias ^^


Última edición por Dehzerus el Miér Sep 28, 2011 1:15 pm, editado 1 vez
Volver arriba Ir abajo
Ver perfil de usuario
Bélsel
Zeratul


Mensajes : 112
Fecha de inscripción : 10/11/2010

MensajeTema: Re: Problema con activadores (Solucionado, se muestra solución)   Miér Sep 28, 2011 7:25 am

Hola!

EL problema está en que has hecho la variable dentro del activador y como su valor inicial es 0 cada vez que el activador se ejecuta es 0.

Cra una variable global y te saldrá.

Otra cosa:

Lo tienes puesto en Zerglings = 6, con lo que ni 8 ni 10 te activaran y los hidras saldran de 2 en 2.


Es mejor usar variables que guardar datos, ya que con las variables se puede hacer más cosas y es más sencillo de usar.


Suerte!
Volver arriba Ir abajo
Ver perfil de usuario
Dehzerus
Zeratul


Mensajes : 107
Fecha de inscripción : 26/04/2011

MensajeTema: Re: Problema con activadores (Solucionado, se muestra solución)   Miér Sep 28, 2011 1:11 pm

Bélsel escribió:
El problema está en que has hecho la variable dentro del activador y como su valor inicial es 0 cada vez que el activador se ejecuta es 0.

Cra una variable global y te saldrá.

Otra cosa:

Lo tienes puesto en Zerglings = 6, con lo que ni 8 ni 10 te activaran y los hidras saldran de 2 en 2.

Gracias! No tenía ni idea de que las variables locales reiniciaban su valor. Lo de los hidras ya lo tenía pensado que no salieran más de 2.

Es que me pasé una hora comprobando todos los activadores y testeandolo todo mirando de que no fallase nada y al final era eso.. Smile
Volver arriba Ir abajo
Ver perfil de usuario
Contenido patrocinado




MensajeTema: Re: Problema con activadores (Solucionado, se muestra solución)   Hoy a las 2:07 pm

Volver arriba Ir abajo
 
Problema con activadores (Solucionado, se muestra solución)
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» Problema de Pedales solucionado
» Problema de audio. (Solucionado)
» (Solucionado) Problema con los retrovisores
» Problema con el mws
» Problema urgente con retrovisores SOLUCIONADO

Permisos de este foro:No puedes responder a temas en este foro.
Starcraft 2 :: Editor de mapas :: Tutoriales avanzados-
Cambiar a: